Browse 3D on mobile

Back to overview

image

Did you know Sketchfab is fully mobile ready? If you check Sketchfab on a mobile device, you’ll see our interface has been designed for it. And the good news is that with the release of iOS8 with WebGl support yesterday, it even works on your iPhone or iPad! The browser wins 🙂

Here are some screenshots of our mobile version: you can do pretty much everything available on the desktop version! There are still a few glitches here and there, we are working hard on fixing those asap.

image

image

Try it now:

 

About the author

Sketchfab Team


Leave a Reply

Your email address will not be published. Required fields are marked *

  • David says:

    Now not working for Chrome or Dolphin on Android

  • Dara says:

    is there a problem with chrome mobile

  • twite_king says:

    any system requirement? my alcatel one touch hero 2 is 3 years old still works nicely as a smartphone. i can load 3d models on chrome with sketchfab standard view, but when i tap vr, it completely freezes, i see onl.y frozon grey grids… i mau not be getting a phone yet, figure i would ask here…

  • Chuck says:

    I have an Android phone Samsung a5. I am using Firefox.
    Any model first comes through as black on black- its only when you change the setting to shadeless or Matcap that you can tell there is something there.
    I have the latest version of both Firefox and the OS-(the issue was there even with the previous versions)
    I have been trying to put a website together to show off my models. Your platform works great on a desktop (windows8.1 and firefox) but not so well from a mobile phone. Lots of people use mobiles these days and I wonder if there is a work around.

  • Nunof says:

    Sketchfab, as of like, 2 weeks ago, has not been working correctly on iOS 10.3.3. Not the app (of which I haven’t downloaded), the website. The website works almost fine, the only bad thing is that every 3D model that’s supposed to load (except for the Mech Drone on Sketchfab’s main page for some reason) instead leaves an empty black screen in it’s place (which turns into a dark-aqua-grey color when I use the Model Inspector to try and bring up a model’s wireframe). Do any admins suppose they can fix the issue so that iOS 10.3.3 beyond doesn’t get this bug?

    • Bart Veldhuizen says:

      Sorry to hear that! I’m not aware of any issues on 10.3.3 – could you please contact support@sketchfab.com and pass them as much information as possible (phone type, url you’re testing, screenshots etc). Thanks!

Related articles